Expedition Exchange Bulletin Boards  

Go Back   Expedition Exchange Bulletin Boards > Technical Discussions
User Name
Password
FAQ Members List Calendar Mark Forums Read


Reply
 
Thread Tools Display Modes
  #1  
Old February 13th, 2005, 09:32 PM
grips03
 
Posts: n/a
04 Disco burning oil

I have a 04 Disco with 3,800 miles. It burns .7 of a quarts per 2000 miles. Is this normal?
Reply With Quote
  #2  
Old February 13th, 2005, 09:37 PM
Snwbord24
 
Posts: n/a
NO. I have an '03 with 53k and no oil leaks (yet).
Reply With Quote
  #3  
Old February 14th, 2005, 06:21 AM
utahdog2003 utahdog2003 is offline
James Reed
KI4PBH
 
Join Date: May 2004
Location: FL
Posts: 50
There is a plastic splash shield under the motor that has a twist-off cap. Remove the cap and feel around on the engine side of the shield for your missing oil. My '03 had an improperly machined oil filter seat that prevented the filter from properly seating against the motor, which resulted in an oil leak similar in quantities to the amount of 'consumption' you describe. You wont see the puddle under the car from the leaking filter seal because the splash shield collects it all, and then the forward motion/wind under the vehicle spreads the oil all over the underside of the truck as you drive.

Should you find oil, the dealer will machine the filter seat to proper spec (there is a service document explaining the problem). Then, remove the cap from the splash shield, swab out all the oily goop being held in the shield and then drill a few half-inch holes in the shield at its lowest points. Then if you have any continued leakage (or any new leakage...it is a Rover after all) you will see the telltale puddle in your parking space as the oil will weep from your newly created holes.
Reply With Quote
  #4  
Old February 14th, 2005, 06:55 AM
KevinNY
 
Posts: n/a
My 04 went through a bit of oil at the very beginning too. It soon stopped and has remained fine since to the current 25K miles.
Reply With Quote
  #5  
Old February 14th, 2005, 08:44 AM
michael
 
Posts: n/a
Quote:
Originally Posted by grips03
I have a 04 Disco with 3,800 miles. It burns .7 of a quarts per 2000 miles. Is this normal?

I have to agree with KevinNY's post above. The first 10K miles on my DSII 04, I was putting in about a 3/4 a quart every couple of thousand miles. Somewhere between 15 and 25K miles the oil consumption dropped off. My 2001 DSII did not have this same oil consumption pattern -- maybe a quarter of a quart now and then in the first 15K; however, my 2004 did burn much more in the beginning.

I was pretty concerned too at first about my 04-- But I am not now.
Reply With Quote
  #6  
Old February 14th, 2005, 10:10 PM
grips03
 
Posts: n/a
Thanks for the replies everyone. I looked under the truck and found no leaking oil, looks clean even on the the splash tray - I've only changed the oil once so far @ 2,000 miles. I guess I'll monitor / fill and let LR know about it a 7,500 mile maint.
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is On
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
"147.555 taking all your disco requests, all weekend long in Anza Borrego" JSQ General 20 June 3rd, 2006 07:56 PM
ECU on a 95 Disco Reddisco1 Technical Discussions 1 July 12th, 2005 12:58 PM
Getting access to Disco headlining cwdavis4 Technical Discussions 7 June 9th, 2004 12:55 AM


All times are GMT -8. The time now is 03:12 PM.




Copyright 2001-2012 Expedition Exchange Incorporated. All rights reserved.
Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.